Investigating elevated repo errors

Incident Report for Gemfury

Resolved

Configuration & scaling improvements seem to be absorbing the traffic spikes more comfortably now. Resolving.
Posted May 20, 2026 - 08:55 PDT

Monitoring

The number of open connections to each server was reaching our configured limit. We have raised the limit. Monitoring.
Posted May 20, 2026 - 06:35 PDT

Investigating

We're seeing unusual traffic to our repositories that are causing elevated errors and timeouts. We've investigating possible ways to mitigate this.
Posted May 20, 2026 - 06:20 PDT
This incident affected: Repo endpoints.