Elevated timeouts from NPM-Proxy

Incident Report for Gemfury

Resolved

Dependency issues are resolved.
Posted Dec 15, 2021 - 08:42 PST

Monitoring

NPM-Proxy errors have subsided on our end. We are monitoring this in the context of the still-open npm issue. We're also looking into whether current AWS internet connectivity problems are affecting our service or its dependencies: https://status.aws.amazon.com
Posted Dec 15, 2021 - 08:07 PST

Identified

We are receiving sporadic 503 errors from the public npm registry. Status seems to reflect the issue: https://status.npmjs.org
Posted Dec 15, 2021 - 07:54 PST

Investigating

We're seeing elevated timeout error rates from proxied requests to the public NPM registry via npm-proxy.fury.io.
Posted Dec 15, 2021 - 07:50 PST
This incident affected: Repo endpoints.